-   FastMail Forum (
-   -   New interface problems (

PON 16 May 2017 01:11 AM

New interface problems
I have reported problems with the new interface before and didn't get any useful information. Trying again now as the problem is repeatable enough for me to have experienced it 3 times so far today.

The problem is this: when I hit send on a message it starts to send and then .... nothing. It never gets sent and I end up having to start again.

Every time it happens I get reminded to Control A and Control C before hitting send but it's hard to do that without fail.

This has NEVER happened to me with the Classic interface in getting on for 15 years. It happens quite FREQUENTLY with the new interface (which is one reason I default to continuing to use the Classic as long as I can, the other being my need to sort contacts on nickname).

It seems to happen more often on messages with attachments than without. If I log out I note that I am presented with a Switch User option afterwards, as if I haven't logged out at all.

I do quite often have more than one session open (e.g., a masteruser account and another account) at the same time (in a private window, possibly with Classic UI but not always), and I have wondered if the cookies of one session were getting picked up incorrectly.

Either way I am not happy. It's particularly annoying when I have to do a screen grab on a hung email and retype it.

Any suggestions?

Last time I posted on this the verdict was "it's your network". It's a limited DSL link but I have had no trouble with any other sites so I remain skeptical about this.

BritTim 16 May 2017 01:34 AM

I do think it likely that your network is implicated. However, I would expect the message to be in the Drafts folder most of the time when this happens. Have you checked that?

PON 16 May 2017 01:43 AM

It's the first thing I check. Last time it happened I had one line of quite a long message in drafts along with a couple of attachments, but not most of the rest of the message.

I have no such issues with Yahoo mail, Gmail or any other website. And if it's the network why no problems ever with the Classic UI?

(Thanks for the quick response btw)

n5bb 16 May 2017 04:49 AM

Save Now feature
I never see this problem unless I'm on a very unreliable network connection. I often have several Fastmail windows open, but they are all on the current user interface.

When you are composing a message you should see the Save Now button at the top changing from time to time between these three states:
  • Save Now (normal)
  • Saving (grey)
  • Saved (grey)
If you are making a significant change to a message you are composing (such as pasting a block or typing in some complex information), you should click the Save Now button after the modification so that the server is updated. You should see the state changing to Saving momentarily, then to Saved. If the state remains in Saving very long (such as 30 seconds) you have a significant problem with the network connection to the Fastmail server.

Once the state is Saved, the copy on the Drafts folder at Fastmail is identical with what you see on your screen. Any changes you then make (typing a single character, for example) will cause the state to change to Save Now so you are warned that the state hasn't been copied to the Fastmail server. I recommend using the Save Now button often when the network connection is poor.


PON 16 May 2017 05:20 AM

I use the Save Now button quite often but not reflexively. I tend to do it when I've come to a pause or when I'm taking an interruption. I touch-type so a few paragraphs doesn't take long.

My connection is a nominal "up to 5Mbps" link but its ACTUAL figures are 2Mbps down and 0.32Mbps up.

Remember: I have been using Fastmail for 15 years and I have used it in places with MUCH WORSE connectivity with NO PROBLEM and I ONLY have issues with the new UI, never with the Classic UI.

BritTim 16 May 2017 04:47 PM

Under most normal circumstances, the UI is more responsive with the modern interface than with classic. That holds even when the network connection is rather slow. However, it is a fact that these kinds of asynchronous interfaces are sensitive to network disruption and lost packets. The old classic interface can be affected too, but to a much lesser degree.

The network speeds you cite, while not very good by today's standards, should be quite adequate for purposes like email, but a short-term network overload leading to lost packets (which I suspect is the cause of the trouble) will mess up the handshaking between your client and FastMail.

PON 16 May 2017 08:29 PM

Checking back here now because... it's happened again.

I simply don't have this problem with ANY other web site or mail system. It's exasperating and I just don't believe it's solely the network and not in any way a UI bug.

It never happens with the Classic UI.
I never have issues with mail clients either (Thunderbird, K9 and Fastmail app on Android)
It is EXCLUSIVELY a problem with the new UI.

When I cancel sending a message (back arrow) I can't connect to my inbox again without logging out but when I do so I'm offered an option to switch user back to the session I've logged out of.

Update: on a hunch I have disabled Privacy Badger for and filed the following to

Chrome Version 57.0.2987.133 on Windows 7. site: I periodically get message sending failures as if I have been logged out. I am not sure but suspect that the gravatar site used by Fastmail may be involved. Something is happening with cookies using the new UI (Classic UI is fine).

This may be entirely wrong but it seems more plausible to me than network problems which exclusively affect the new UI.

n5bb 17 May 2017 12:09 AM


Originally Posted by PON (Post 601854)
...When I cancel sending a message (back arrow) I can't connect to my inbox again without logging out but when I do so I'm offered an option to switch user back to the session I've logged out of.

Update: on a hunch I have disabled Privacy Badger for and filed the following to

I recommend not using the browser back button to cancel the Compose screen. Instead use the Discard button or click Inbox or another folder if you wish to keep the draft.

Try using a browser with no add-ons.


PON 17 May 2017 04:55 AM

Neither works. It appears that my connection to the session is somehow up the spout.

I run several things to stay free of malware and unwanted advertising: pihole for DNS, ublock Origin, Adblock plus, Privacy Badger, Tab Cookies, Https everywhere, and Disconnect.

But the only site I have issues with is Fastmail with the new UI.

None of the things I use are unusual. All are used by millions of people.

PON 19 May 2017 12:43 AM

With my browser plugins set to whitelist I continue to have intermittent "Sending..." problems using the new interface.

However, unlike Elvey, I get no error message, just a hang.

It seems that this is much more likely to occur after I receive a message with an attachment and the odds increase as the number of attachments goes up.

This is not untypical:

I receive a message with attachments.
I read it, download the attachments, hit reply.... browser shows the undulating histogram and never returns
I back out, hit Compose, enter a message, hit Send, browser says "Sending..." and never does.

Terry 19 May 2017 01:58 PM

I suppose you have tried deleting your cache and cookies in your browser.

Are you trying to email someone on google or it is anyone.

odedp 19 May 2017 03:43 PM

same here...
I'm trying to send a very small attachment (98k) and get stuck... nothing happens...
It's the first time something like this happens to me...

odedp 19 May 2017 03:46 PM

This happens only if there is an attachment enclosed.
Sending emails without attachments works flawlessly.

odedp 19 May 2017 03:49 PM

Also forwarding messages with attachments doesn't work :o

odedp 19 May 2017 06:08 PM

OK now
Now it's working OK... :)

All times are GMT +9. The time now is 08:01 AM.

Copyright 1998-2013. All Rights Reserved. Privacy Policy