EmailDiscussions.com

EmailDiscussions.com (http://www.emaildiscussions.com/index.php)
-   Email Comments, Questions and Miscellaneous (http://www.emaildiscussions.com/forumdisplay.php?f=8)
-   -   ProtonMail - Encrypted Email (http://www.emaildiscussions.com/showthread.php?t=68880)

rockman 27 Apr 2014 05:40 AM

ProtonMail - Encrypted Email
 
https://protonmail.ch/

Hosted in Switzerland
More flexible than Mail1Click - you can send/receive email easily with non-ProtonMail users.
Optionally password encrypt email to non-ProtonMail users
Email expirations
Two passwords: one to authenticate with the service and another to decrypt mailbox client-side. The mailbox password is not shared with ProtonMail. Therefore, zero knowledge.

jarland 27 Apr 2014 06:23 AM

Nice find! Requested beta invite. I'm excited by anyone stepping up to the plate to hit the ball that lavabit had ripped from their hands.

janusz 27 Apr 2014 04:20 PM

Quote:

Originally Posted by jarland (Post 570693)
I'm excited by anyone stepping up to the plate to hit the ball that lavabit had ripped from their hands.

3 in 1 (three metaphors in one sentence) :D

me0000 28 Apr 2014 05:14 AM

If you go the log in page:

https://protonmail.ch/login.php

Scroll to the bottom, click sign up and it allows you to sign up !

ccl1 28 Apr 2014 11:25 PM

that sign up link is the same as the link requesting access to the beta.

xmailer 28 Apr 2014 11:51 PM

I've supposedly received an account in reply to my request. First it took quite awhile before the link would even respond adequately to open the account in the first place. After repeating the procedure from the original emailed link, I was eventually able to apparently fully open the account, where I found a welcome message which was readable, but I've been unable to as much as send that or any other email message by the simple expedient of clicking on an apparent "send" link, which appeared to do nothing.

Nor do many, if any, other of the links appear to do anything, or at least anything "useable". I was able to post a "problem" ticket of a sort, merely reporting that I appear to be able to do essentially nothing, for whatever good that will do. So far, I remain entirely unimpressed.

Fenman 28 Apr 2014 11:59 PM

It's not working too well for me just now. I received the offer of a beta account this morning and signed up. I sent myself a test email and it worked fine.

Now, 6hrs or so later, it refuses to let me log in with the credentials I set up this morning BUT it let me register all over again with the original user name. :confused:

rockman 29 Apr 2014 12:12 AM

Quote:

Originally Posted by Fenman (Post 570741)
It's not working too well for me just now. I received the offer of a beta account this morning and signed up. I sent myself a test email and it worked fine.

Now, 6hrs or so later, it refuses to let me log in with the credentials I set up this morning BUT it let me register all over again with the original user name. :confused:

I'd suggest you follow the advice from your welcome email... ;)

Quote:

"A quick word of warning! ProtonMail is still in BETA so it might not be 100% reliable yet. We suggest that you don't use yet it to store emails you can't afford to lose.

If you happen to find a bug, we would really appreciate it if you use the Report Bug button in the top right to let us know.

We're constantly working to improve ProtonMail (especially during BETA) and we'll be fixing bugs and adding new features daily. You can follow the latest updates at our blog: https://protonmail.ch/blog/

Finally, if you have feedback or would like to request a feature, wed love to hear from you!

just send an email to features@protonmail.ch"

rockman 29 Apr 2014 12:13 AM

Quote:

Originally Posted by xmailer (Post 570740)
I've supposedly received an account in reply to my request. First it took quite awhile before the link would even respond adequately to open the account in the first place. After repeating the procedure from the original emailed link, I was eventually able to apparently fully open the account, where I found a welcome message which was readable, but I've been unable to as much as send that or any other email message by the simple expedient of clicking on an apparent "send" link, which appeared to do nothing.

Nor do many, if any, other of the links appear to do anything, or at least anything "useable". I was able to post a "problem" ticket of a sort, merely reporting that I appear to be able to do essentially nothing, for whatever good that will do. So far, I remain entirely unimpressed.

Ping the devs with your problems. Only they can help.
Quote:

"A quick word of warning! ProtonMail is still in BETA so it might not be 100% reliable yet. We suggest that you don't use yet it to store emails you can't afford to lose.

If you happen to find a bug, we would really appreciate it if you use the Report Bug button in the top right to let us know.

We're constantly working to improve ProtonMail (especially during BETA) and we'll be fixing bugs and adding new features daily. You can follow the latest updates at our blog: https://protonmail.ch/blog/

Finally, if you have feedback or would like to request a feature, wed love to hear from you!

just send an email to features@protonmail.ch"

communicant 29 Apr 2014 01:24 AM

For me, some of the links on some pages of the site are dead. Many of them do work, but when I'm at the sign-up page, the 'check availability' button is dead, and so is the 'request invite' button to submit the form. The captcha numbers are visible, but there seems to be no field in which to enter them. Has anyone else experienced these problems?

rockman 29 Apr 2014 01:36 AM

Quote:

Originally Posted by communicant (Post 570750)
For me, some of the links on some pages of the site are dead. Many of them do work, but when I'm at the sign-up page, the 'check availability' button is dead, and so is the 'request invite' button to submit the form. The captcha numbers are visible, but there seems to be no field in which to enter them. Has anyone else experienced these problems?

No. I'm using IE11.

ProtonMail 29 Apr 2014 02:25 AM

ProtonMail Support
 
Hi everyone,

I'm Jason Stockman, a developer with ProtonMail. We're discovering (thanks to Beta support tickets and this forum thread actually) that we have some Javascript bugs related to the UI and animations in Firefox on Linux and unfortunately those errors are breaking core functionality on the Compose pages. We should have a fix in place over the next hour or so, but in the meantime if you'd like to try things out you may have better luck with Safari or Chrome, at least until we have a Firefox patch in place this afternoon.

We do expect a lot of usability bugs over the next few days, but it's a shame this specific bug prevents core functionality. It's likely a bug that I personally wrote as the front-end developer and I'm sorry about that.

I hope you'll come back and give us another try later today.

If anyone else has a problem at all with the site, you can contact me/us directly through our site or post here - we'll keep an on eye on both sides!

Cheers,
Jason

xmailer 29 Apr 2014 02:35 AM

Quote:

Originally Posted by rockman (Post 570743)
Ping the devs with your problems. Only they can help.

Like I said, I did.

xmailer 29 Apr 2014 02:41 AM

Quote:

Originally Posted by ProtonMail (Post 570756)
Hi everyone,

I'm Jason Stockman, a developer with ProtonMail. We're discovering (thanks to Beta support tickets and this forum thread actually) that we have some Javascript bugs related to the UI and animations in Firefox on Linux and unfortunately those errors are breaking core functionality on the Compose pages. We should have a fix in place over the next hour or so, but in the meantime if you'd like to try things out you may have better luck with Safari or Chrome, at least until we have a Firefox patch in place this afternoon.

We do expect a lot of usability bugs over the next few days, but it's a shame this specific bug prevents core functionality. It's likely a bug that I personally wrote as the front-end developer and I'm sorry about that.

I hope you'll come back and give us another try later today.

If anyone else has a problem at all with the site, you can contact me/us directly through our site or post here - we'll keep an on eye on both sides!

Cheers,
Jason

I'll be glad to try it any time that it may be convenient. However I routinely use Firefox, and although I can't say I would never again change browsers, I'm not inclined to permanently change browsers now only to use a single email service, since literally everything else I do online works fine with Firefox and it's what I'm accustomed to using and finding all the options for, etc. But I'll be glad to wait however long it may take for better Firefox functionality.

rockman 29 Apr 2014 02:41 AM

Quote:

Originally Posted by xmailer (Post 570757)
Like I said, I did.

I didn't read that in your post. Now that Jason is here, I am sure he will attempt to "impress" you with some help. :D


All times are GMT +9. The time now is 12:56 AM.


Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy