EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 26 Mar 2003, 07:11 PM   #1
Jeremy Howard
Ultimate Contributor
 
Join Date: Sep 2001
Location: Australia
Posts: 11,499
Minor CSS print-view fix

If you choose 'print view' on the View screen, there's a 'Return' link in the top-right to get back to the normal view. Of course, this really shouldn't be printed.

So, I've just added a 'noprint' style to the Professional Blue style-sheet, and used this for that link. I've tested on Mozilla, and indeed that link is not shown when printing.

I'd be interested to hear reports of whether this works on IE and Opera, and also if anyone has other ideas for this kind of functionality.
Jeremy Howard is offline   Reply With Quote

Old 26 Mar 2003, 11:51 PM   #2
AndrewL
Junior Member
 
Join Date: Feb 2003
Location: Cambridge, UK
Posts: 27
Thanks Jeremy for a nice refinement to the print view.

This works fine with IE 6 service pack 1 on Windows 2000 Workstation service pack 3.

Cheers,


Andrew
AndrewL is offline   Reply With Quote
Old 27 Mar 2003, 12:49 AM   #3
Mal
Senior Member
 
Join Date: May 2002
Location: Wanstead, England
Posts: 170
Works fine in IE 5.5

== Mal
Mal is offline   Reply With Quote
Old 27 Mar 2003, 03:26 AM   #4
Meow
Junior Member
 
Join Date: Jun 2002
Location: San Francisco
Posts: 7
Smile Works in Opera 6.06b WNT4.0sp6

Hmm, I almost never print email. Didn't even see the feature. Lean something new every day.

Yes, it works with Opera 6.06b on Windows NT 4.0 SP6.

(I won't try it with Opera 7. I don't like Opera 7 since it doesn't work with Citibank.)

But, I don't use the Professional Blue sheet. I use Concise Large because it takes less horizontal real estate. I guess now I'll have to muck about with making my own style sheet which combines all the features I like.


Meow is offline   Reply With Quote
Old 27 Mar 2003, 04:52 AM   #5
AndrewL
Junior Member
 
Join Date: Feb 2003
Location: Cambridge, UK
Posts: 27
Re: Works in Opera 6.06b WNT4.0sp6

Quote:
Originally posted by Meow
But, I don't use the Professional Blue sheet. I use Concise Large because it takes less horizontal real estate. I guess now I'll have to muck about with making my own style sheet which combines all the features I like.
I also don't normally use 'Professional Blue' either, but Jeremy's refinement to the print view still works. Currently the print view always uses the 'Professional Blue' stylesheet no matter what stylesheet you have selected in Preferences. I've checked this by viewing the HTML source of a print view page.

Jeremy, is this behaviour intentional? In some circumstances, allowing the user selected stylesheet to affect the print view could be useful.

Cheers,


Andrew
AndrewL is offline   Reply With Quote
Old 27 Mar 2003, 07:03 AM   #6
Adrian Bell
Cornerstone of the Community
 
Join Date: Apr 2001
Location: Darlington, UK
Posts: 928
Jeremy, I've not used the "Print View" Option before as I mainly use a client, but I decided to try it. For me it shows all the HTML codes in the message for a HTML mail. This is with IE6 & Netscape 7.0, is this how it is supposed to work?
Adrian Bell is offline   Reply With Quote
Old 27 Mar 2003, 08:32 AM   #7
Jeremy Howard
Ultimate Contributor
 
Join Date: Sep 2001
Location: Australia
Posts: 11,499
No, it's not how it's supposed to work. I believe that Nico has fixed this bug in the development version, however.
Jeremy Howard is offline   Reply With Quote
Old 27 Mar 2003, 09:31 AM   #8
SanjaySheth
Master of the @
 
Join Date: Mar 2002
Location: Chicago
Posts: 1,079
Adrian, are you sure about that? I tried it out on several html emails (both in framed and inline mode) and they all seem to work properly in print view mode on IE6.

Perhaps, send the email to webmasterATfastmail.fm for review.
SanjaySheth is offline   Reply With Quote
Old 27 Mar 2003, 10:38 AM   #9
mklose
Cornerstone of the Community
 
Join Date: Apr 2002
Location: Germany
Posts: 693
Send yourself a normal email from hotmail to fastmail.

It will show the HTML tags (mainly DIVs) in the print preview, will not show them though in any other "normal" view.
mklose is offline   Reply With Quote
Old 28 Mar 2003, 06:00 AM   #10
Adrian Bell
Cornerstone of the Community
 
Join Date: Apr 2001
Location: Darlington, UK
Posts: 928
Quote:
Originally posted by SanjaySheth
Adrian, are you sure about that?
Yes, it still does it. See Here.
Adrian Bell is offline   Reply With Quote
Old 28 Mar 2003, 08:04 AM   #11
AndrewL
Junior Member
 
Join Date: Feb 2003
Location: Cambridge, UK
Posts: 27
I think I can reproduce the behaviour that Adrian and mklose see.

If you do not have the 'View HTML' option selected in Preferences then the 'Print View' shows the raw HTML code. If the 'View HTML' option is selected then the print view renders the HTML properly.

Adrian, can you confirm this? Do you have the 'View HTML' option selected? If not, then selecting it should correct the print view of HTML messages.

Although this is a workaround, I think the underlying issue is still a bug. Many users will disable HTML viewing for security reasons (web bugs, etc.). Surely when the user has disabled HTML viewing of messages, the print view should use the plain text part or run the HTML through lynx if the message doesn't have a plain text part.

Regards,


Andrew
AndrewL is offline   Reply With Quote
Old 28 Mar 2003, 08:06 AM   #12
Jeremy Howard
Ultimate Contributor
 
Join Date: Sep 2001
Location: Australia
Posts: 11,499
Thanks for the diagnostics, Andrew. Well done! I'll pass that on to Nico.
Jeremy Howard is offline   Reply With Quote
Old 28 Mar 2003, 08:26 AM   #13
mklose
Cornerstone of the Community
 
Join Date: Apr 2002
Location: Germany
Posts: 693
I can certainly confirm that I have text view as a standard set up in my prefs (NOT HTML).
mklose is offline   Reply With Quote
Old 29 Mar 2003, 04:06 AM   #14
Adrian Bell
Cornerstone of the Community
 
Join Date: Apr 2001
Location: Darlington, UK
Posts: 928
Quote:
Originally posted by mklose
I can certainly confirm that I have text view as a standard set up in my prefs (NOT HTML).
Yes me too, AndrewL you are correct.
Quote:
Originally posted by AndrewL
Surely when the user has disabled HTML viewing of messages, the print view should use the plain text part or run the HTML through lynx if the message doesn't have a plain text part.
Yes, I agree.

Last edited by Adrian Bell : 29 Mar 2003 at 04:09 AM.
Adrian Bell is offline   Reply With Quote
Old 9 Aug 2003, 04:49 AM   #15
NumberSix
Cornerstone of the Community
 
Join Date: Jan 2003
Location: The Village
Posts: 556
Still no fix?

I'd like to report that this bug/annoyance still exists, at least for the Netscape 7.0/Solaris that I use at work.
NumberSix is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 08:30 AM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy