EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 11 Sep 2019, 06:13 PM   #1
katchy
Junior Member
 
Join Date: Jul 2015
Posts: 6
FM Fonts look strange after upgrading to Chrome 77

Last night Chrome upgraded to v77 and now all the fonts in FM look less smooth, more square and blocklike , than they did before.

Anyone else have the same problem?
katchy is offline   Reply With Quote

Old 11 Sep 2019, 09:07 PM   #2
BritTim
The "e" in e-mail
 
Join Date: May 2003
Location: mostly in Thailand
Posts: 2,810
I think Google has recently made changes to the default fonts in Chrome, I am not very sensitive to such things (I grew up with the old green screens and can tolerate anything). If it bothers you, you can probably adjust the Chrome default font settings to achieve something more to your liking.
BritTim is offline   Reply With Quote
Old 11 Sep 2019, 09:49 PM   #3
katchy
Junior Member
 
Join Date: Jul 2015
Posts: 6
From googling and checking my settings I dont think the defaults have changed. And I cant imagine that FM wouldn't specify display elements for every item on the page.

I didnt get too deep into it but there are font css settings on the mesg list page. And I am now getting errors in the chrome console :

Quote:
6Refused to load the font '<URL>' because it violates the following Content Security Policy directive: "font-src 'self' data:".

www.fastmail.com/:1 Refused to load the font 'http://themes.googleusercontent.com/static/fonts/rosarivo/v1/OGdIq-p0tOtBN2VMVvO9W_esZW2xOQ-xsNqO47m55DA.woff' because it violates the following Content Security Policy directive: "font-src 'self' data:".

www.fastmail.com/:1 Refused to load the font 'http://themes.googleusercontent.com/static/fonts/inconsolata/v5/BjAYBlHtW3CJxDcjzrnZCIbN6UDyHWBl620a-IRfuBk.woff' because it violates the following Content Security Policy directive: "font-src 'self' data:".

VM1204:121 Refused to load the font 'http://themes.googleusercontent.com/static/fonts/rosarivo/v1/OGdIq-p0tOtBN2VMVvO9W_esZW2xOQ-xsNqO47m55DA.woff' because it violates the following Content Security Policy directive: "font-src 'self' data:".

(anonymous) @ VM1204:121
VM1204:121 Refused to load the font 'http://themes.googleusercontent.com/static/fonts/rosarivo/v1/OGdIq-p0tOtBN2VMVvO9W_esZW2xOQ-xsNqO47m55DA.woff' because it violates the following Content Security Policy directive: "font-src 'self' data:".

(anonymous) @ VM1204:121
VM1204:121 Refused to load the font 'http://themes.googleusercontent.com/static/fonts/inconsolata/v5/BjAYBlHtW3CJxDcjzrnZCIbN6UDyHWBl620a-IRfuBk.woff' because it violates the following Content Security Policy directive: "font-src 'self' data:".

(anonymous) @ VM1204:121
VM1204:121 Refused to load the font 'http://themes.googleusercontent.com/static/fonts/inconsolata/v5/BjAYBlHtW3CJxDcjzrnZCIbN6UDyHWBl620a-IRfuBk.woff' because it violates the following Content Security Policy directive: "font-src 'self' data:".
katchy is offline   Reply With Quote
Old 11 Sep 2019, 10:39 PM   #4
BritTim
The "e" in e-mail
 
Join Date: May 2003
Location: mostly in Thailand
Posts: 2,810
Quote:
Originally Posted by katchy View Post
And I am now getting errors in the chrome console :
Odd, when I saw your original report, I specifically looked at the Chrome console and saw no errors. Which OS are you using? Have you tried opening an incognito window with extensions disabled to see if FastMail then looks different?
BritTim is offline   Reply With Quote
Old 11 Sep 2019, 11:43 PM   #5
katchy
Junior Member
 
Join Date: Jul 2015
Posts: 6
Im using windows. I started up a portableapps version of chrome - no extensions.
It looks similarly broken as the other chrome instance

No font errors but I did get
Quote:
Failed to load resource: the server responded with a status of 404 (Not Found)

https://www.fastmailusercontent.com/...TBmYWZjOWRmOC8
this sort of error appears in the original instance too.
katchy is offline   Reply With Quote
Old 12 Sep 2019, 02:43 PM   #6
n5bb
Intergalactic Postmaster
 
Join Date: May 2004
Location: Irving, Texas
Posts: 8,544
Fastmail looks fine to me with no font issues in Chrome 77.0.3865.75 (64-bit).
  • Your second post contained only CSP (Content Security Policy) errors which caused fonts to not load. Your issue might be caused by browser extensions.I don't see any CSP violations at the Fastmail website using Chrome 77 on a Windows 10 PC.
  • Your third post shows a failure to load something from the Fastmail sandbox site (www.fastmailusercontent.com.
    • That special site is used to serve external content to your browser so that someone can't send you an email and discover your IP address when it's downloaded from the external site to your browser. So Fastmail loads the content from their end (and so their IP) and then your browser gets it from that www.fastmailusercontent.com content site.
    • Fastmail could just load the content every time you open a different message in the list. But to improve performance I believe they cache message content, and it appears to me that there is caching both in your browser and at the www.fastmailusercontent.com site.
    • So in some cases you can select a message and it loads immediately with no errors. But if the cache entry for that message is stale or missing you can get a 404 error (not found). The cache is then refreshed and the content is sent to the browser using jmap protocol.
    • So after testing this for a while (reading messages in various orders), I believe this is a cache miss transient "error". Not really a problem. It's just how cached systems work.
  • More about Content Security Policy and why email content is served through a different site:
Bill
n5bb is offline   Reply With Quote
Old 12 Sep 2019, 06:20 PM   #7
katchy
Junior Member
 
Join Date: Jul 2015
Posts: 6
Google tells me Chrome has a new font rendering engine in 77 and some people find it harder to read . That said here are screenshots of the differences:

Chrome 76 : https://i.vgy.me/q2DPMp.png

Chrome 77 : https://i.vgy.me/30OhWV.png

I guess the bold fonts are bolder and therefore harder for me to read.
katchy is offline   Reply With Quote
Old 12 Sep 2019, 06:27 PM   #8
n5bb
Intergalactic Postmaster
 
Join Date: May 2004
Location: Irving, Texas
Posts: 8,544
I can't tell any difference (except for the slightly different width) unless I zoom it up to a large size. So I'm obviously not bothered by the change.
n5bb is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 10:27 PM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy