EmailDiscussions.com  

Go Back   EmailDiscussions.com > Miscellaneous > The Off-Topic Lounge
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

The Off-Topic Lounge APPROPRIATE FAMILY-FRIENDLY TOPICS ONLY - READ THE RULES!
This forum is for posting anything (excluding topics prohibited by the forum rules) that's unrelated to email. General discussions, in other words.

Reply
 
Thread Tools
Old 19 Jan 2005, 04:11 AM   #1
JshLnsctt
Junior Member
 
Join Date: Dec 2004
Posts: 17
Speed Up Firefox!

If you don't have FireFox yet get it here!


Quote:
1.Type “about:config” into the address bar and hit return. Scroll down and look for the following entries:

network.http.pipelining network.http.proxy.pipelining network.http.pipelining.maxrequests

Normally the browser will make one request to a web page at a time. When you enable pipelining it will make several at once, which really speeds up page loading.

2. Alter the entries as follows:

Set “network.http.pipelining” to “true”

Set “network.http.proxy.pipelining” to “true”

Set “network.http.pipelining.maxrequests” to some number like 30. This means it will make 30 requests at once.

3. Lastly right-click anywhere and select New-> Integer. Name it “nglayout.initialpaint.delay” and set its value to “0”. This value is the amount of time the browser waits before it acts on information it receives.

browser.turbo.enabled True

If you’re using a broadband connection you’ll load pages MUCH faster now!

Last edited by JshLnsctt : 22 Jan 2005 at 03:54 AM.
JshLnsctt is offline   Reply With Quote

Old 19 Jan 2005, 05:06 AM   #2
xbot
Cornerstone of the Community
 
Join Date: Aug 2004
Location: Michigan
Posts: 922

Representative of:
xxos.us
I did that already awhile ago.

It works too. It's no trick
xbot is offline   Reply With Quote
Old 19 Jan 2005, 05:37 AM   #3
sparky752
Senior Member
 
Join Date: Oct 2003
Posts: 118
Re: Speed Up Firefox!

Quote:
3. Lastly right-click anywhere and select New-> Integer. Name it “nglayout.initialpaint.delay” and set its value to “0”. This value is the amount of time the browser waits before it acts on information it receives.
I saw on a website (I dont remember which) that this could actually slow down browsing . Basically, it will load one thing at a time instead of loading everything at once, which uses more CPU. I have had this option turned on for awhile so I turned it off and tried it out. For me it actually slowed down browsing . So use at your own risk.

All the other options are fine as far as I know.
sparky752 is offline   Reply With Quote
Old 19 Jan 2005, 06:55 AM   #4
JshLnsctt
Junior Member
 
Join Date: Dec 2004
Posts: 17
It's speeds mine up so I guess people will have to try it both ways
JshLnsctt is offline   Reply With Quote
Old 19 Jan 2005, 09:34 AM   #5
dantheman
Cornerstone of the Community
 
Join Date: Mar 2002
Location: Hot Springs, AR
Posts: 856
Re: Re: Speed Up Firefox!

Quote:
Originally posted by sparky752
I saw on a website (I dont remember which) that this could actually slow down browsing . Basically, it will load one thing at a time instead of loading everything at once, which uses more CPU. I have had this option turned on for awhile so I turned it off and tried it out. For me it actually slowed down browsing . So use at your own risk.

All the other options are fine as far as I know.
That may be true for some.

I've tried all the options before adding this one and this last one helped it to be even quicker (the other tips helped too).

Running XP Home on dial-up.

-p.s. actually, i've skipped that "browser turbo set to true" part as i overlooked it. Setting it to true seemed to slow down Firefox and K-Meleon.



Oh! I forgot to say THANK YOU to JshLnsctt !!!
It's the best tweak i've tested yet!

Last edited by dantheman : 19 Jan 2005 at 07:08 PM.
dantheman is offline   Reply With Quote
Old 21 Jan 2005, 08:52 AM   #6
great_sea
Junior Member
 
Join Date: Jan 2005
Location: Pennsylvania, USA
Posts: 5
hmm... works mostly

for some reason everything seems to load much faster except that now the the whole .wikipedia.org website is quite sluggish. of course, maybe their server is just particularly overrun with traffic today.
either way i guess i will post again if it starts working well or if it continues to be slow. thanks for the tweak either way.
great_sea is offline   Reply With Quote
Old 21 Jan 2005, 09:04 AM   #7
JshLnsctt
Junior Member
 
Join Date: Dec 2004
Posts: 17
If you want to test to see if it is slowing it down:
If you have IE try going to that site with IE and see if it is about as slow or faster
JshLnsctt is offline   Reply With Quote
Old 21 Jan 2005, 09:47 AM   #8
badkarma
Cornerstone of the Community
 
Join Date: Sep 2004
Location: Illinois
Posts: 626
Is there anything special I have to set before entering :config in the address bar? All I get is a brand new untitled tab.

Edit: never mind - should be about:config with no space before the colon

Last edited by badkarma : 21 Jan 2005 at 10:02 AM.
badkarma is offline   Reply With Quote
Old 21 Jan 2005, 09:21 PM   #9
euroman
Senior Member
 
Join Date: Sep 2004
Posts: 136
If it does slow down - how do you retore defaults??? I think it does slow don on my system (Firefox 1.o on win XP home, P4 Toshiba)
euroman is offline   Reply With Quote
Old 22 Jan 2005, 01:55 AM   #10
xbot
Cornerstone of the Community
 
Join Date: Aug 2004
Location: Michigan
Posts: 922

Representative of:
xxos.us
Quote:
Originally posted by euroman
If it does slow down - how do you retore defaults??? I think it does slow don on my system (Firefox 1.o on win XP home, P4 Toshiba)
Try going to about:config and just undoing what you did.

Remember the values if you're that concerned. Honestly few have reported problems and those that did disabled the last one and it worked fine.
xbot is offline   Reply With Quote
Old 22 Jan 2005, 03:53 AM   #11
JshLnsctt
Junior Member
 
Join Date: Dec 2004
Posts: 17
I am sorry I put the space there, I will fix it. It is about:config


Edit: Guess I can't edit it because in the post at the top there are no spaces when I hit edit
JshLnsctt is offline   Reply With Quote
Old 22 Jan 2005, 04:24 AM   #12
xbot
Cornerstone of the Community
 
Join Date: Aug 2004
Location: Michigan
Posts: 922

Representative of:
xxos.us
Quote:
Originally posted by JshLnsctt
I am sorry I put the space there, I will fix it. It is about:config


Edit: Guess I can't edit it because in the post at the top there are no spaces when I hit edit
Same here.

It appears it's an EMD bug.

Try putting under code, like this.

Code:
about:config
EDIT: Nevermind. That doesn't work either.

Something about t: or :c . Hmm..
xbot is offline   Reply With Quote
Old 22 Jan 2005, 04:24 AM   #13
war17
The "e" in e-mail
 
Join Date: Jul 2004
Location: California
Posts: 3,452
Quote:
Originally posted by euroman
If it does slow down - how do you retore defaults??? I think it does slow don on my system (Firefox 1.o on win XP home, P4 Toshiba)
Once you add a configuration line, you cannot delete it in about:config. You can reset it to have no value. Right click on the line nglayout.initialpaint.delay and select Reset.
war17 is offline   Reply With Quote
Old 22 Jan 2005, 04:27 AM   #14
badkarma
Cornerstone of the Community
 
Join Date: Sep 2004
Location: Illinois
Posts: 626
Quote:
Originally posted by JshLnsctt
I am sorry I put the space there, I will fix it. It is about:config
Quite alright. It's something to do with this web editor. I tried it in double-quotes, with a backslash, but it's the editor apparently.
badkarma is offline   Reply With Quote
Old 22 Jan 2005, 05:48 AM   #15
ROBERT.BAK
Essential Contributor
 
Join Date: Jun 2000
Location: Backup of [email protected]
Posts: 245
The same sort of thing happened when I typed "about:mozilla" (without the quotes, but within a {url} container) in an earlier thread.
ROBERT.BAK is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 02:52 AM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy