EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 26 May 2022, 01:32 PM   #1
gardenweed
Cornerstone of the Community
 
Join Date: Jun 2008
Location: Perth
Posts: 647
Image links not appearing

Sometimes I receive email that I know have image links - sometimes that's all they have - but the image links do not appear in the FM web interface.
The email will look totally empty.

However, if I use MS Outlook, the image link will show and Outlook will offer to download the image if I want.

My FM settings are set to "Show remote images from senders in my contacts, otherwise ask"
In this instance the sender is not in my contacts list, so I am not expecting to see the image loaded, but I am expecting to see the option to load the image.
However the body of the email looks totally empty in the FM web UI.
When I open the email in Outlook, the image link is offered to be downloaded by Outlook.

This does not happen to all email that is not in my contact list.
Usually I will see an option to download the image.

I screen all email that is not coming from someone in my contacts list into a folder called "Screen".

Has anyone seen this behaviour where there is no image link observed in the body of an email using the web UI, but when using an email client the image link appears?

Quick update - I have also looked at the raw message in FM and tried searching for the link address (as seen in Outlook), but there is no evidence of the link address in the raw message.

Last edited by gardenweed : 26 May 2022 at 01:34 PM. Reason: More info added
gardenweed is offline   Reply With Quote

Old 26 May 2022, 04:53 PM   #2
JeremyNicoll
Essential Contributor
 
Join Date: Dec 2017
Location: Scotland
Posts: 376
Quote:
Originally Posted by gardenweed View Post
Quick update - I have also looked at the raw message in FM and tried searching for the link address (as seen in Outlook), but there is no evidence of the link address in the raw message.
Don't FM proxy the image-fetch process (so their server fetches them, not you)? If they do then the link will be to an image file on one of their servers not the original location (which is what you'd see in Outlook if they don't proxy image fetches).

So I think I'd expect to see image links, but not the original ones.

The code that FM use to replace the links (if they do do that), plus the code that converts a raw message into html that will look like the original contents of the raw message must be pretty complicated. I'd think that if a raw message genuinely has no content apart from image links such code, which might be written in terms of finding image links enclosed by other things and then replacing the parts between the other things, might not cope with content that doesn't have stuff before and after each link.

In any case I think you'll need to raise a ticket and give FM examples of specific mails that are not being processed properly.
JeremyNicoll is offline   Reply With Quote
Old 26 May 2022, 05:18 PM   #3
gardenweed
Cornerstone of the Community
 
Join Date: Jun 2008
Location: Perth
Posts: 647
Quote:
Originally Posted by JeremyNicoll View Post
....

So I think I'd expect to see image links, but not the original ones.

.....
I agree. But in certain cases the body of the email is totally empty.

Raising a ticket as you suggest is probably the way to go.
But the pain...
gardenweed is offline   Reply With Quote
Old 26 May 2022, 08:26 PM   #4
evfrson
Senior Member
 
Join Date: Oct 2015
Location: London/Tokyo/Dubai
Posts: 128
Had the same problem in the FM web interface and also a problem where the link would show and when I tried to download the image it never worked.
This didn't happen with all senders only particular ones but enough to be annoying.
I raised a ticket and their response was it was the fault of the sender in that their server SSL certificate chain was broken and they suggested I contact the sender directly.
The sender in question was Barclays bank and somehow I don't think they would take notice of me complaining about their broken SSL, so I just gave up.
evfrson is offline   Reply With Quote
Old 26 May 2022, 08:47 PM   #5
hadaso
The "e" in e-mail
 
Join Date: Oct 2002
Location: Holon, Israel.
Posts: 4,652
Quote:
Originally Posted by evfrson View Post
...The sender in question was Barclays bank and somehow I don't think they would take notice of me complaining about their broken SSL, so I just gave up.
Or perhaps the sender was claiming to be Barclays bank but the SSL didn't match the claim.
hadaso is offline   Reply With Quote
Old 26 May 2022, 11:53 PM   #6
evfrson
Senior Member
 
Join Date: Oct 2015
Location: London/Tokyo/Dubai
Posts: 128
Quote:
Originally Posted by hadaso View Post
Or perhaps the sender was claiming to be Barclays bank but the SSL didn't match the claim.
No, it was a genuine email that I receive on a regular basis reminding me that my latest statement is available.
I have since changed my contact email address for Barclays bank and I can see the content of the emails without a problem.
evfrson is offline   Reply With Quote
Old 27 May 2022, 08:33 AM   #7
gardenweed
Cornerstone of the Community
 
Join Date: Jun 2008
Location: Perth
Posts: 647
Quote:
Originally Posted by evfrson View Post
No, it was a genuine email that I receive on a regular basis reminding me that my latest statement is available.
I have since changed my contact email address for Barclays bank and I can see the content of the emails without a problem.
In my case it is also a genuine email from a health insurance company.

Quote:
Originally Posted by evfrson View Post
...I raised a ticket and their response was it was the fault of the sender in that their server SSL certificate chain was broken and they suggested I contact the sender directly....
Interesting response from FM.
Do you recall if you tried looking at the email using a client (eg Outlook) and whether the link that was not visible in the FM web UI was visible when using the email client?
gardenweed is offline   Reply With Quote
Old 27 May 2022, 01:41 PM   #8
gardenweed
Cornerstone of the Community
 
Join Date: Jun 2008
Location: Perth
Posts: 647
I raised a ticket.
gardenweed is offline   Reply With Quote
Old 27 May 2022, 01:45 PM   #9
evfrson
Senior Member
 
Join Date: Oct 2015
Location: London/Tokyo/Dubai
Posts: 128
Quote:
Originally Posted by gardenweed View Post
Interesting response from FM.
Do you recall if you tried looking at the email using a client (eg Outlook) and whether the link that was not visible in the FM web UI was visible when using the email client?
Yes I used the Apple Mail app (on both Mac and iPhone) and the missing links were visible and also the images that had links but would not load in the FM interface were loading without problems in the app.
evfrson is offline   Reply With Quote
Old 27 May 2022, 11:07 PM   #10
gardenweed
Cornerstone of the Community
 
Join Date: Jun 2008
Location: Perth
Posts: 647
FM support response so far....

Quote:
The issue here is that the HTML part of this email contains some invalid encoding, which is causing our parser to truncate it, in this case before the visible content even begins. I've filed a ticket for our backend team to investigate handling this better.
Maybe something will come of this??
gardenweed is offline   Reply With Quote
Old 27 May 2022, 11:47 PM   #11
BritTim
The "e" in e-mail
 
Join Date: May 2003
Location: mostly in Thailand
Posts: 3,017
Quote:
Originally Posted by gardenweed View Post
FM support response so far....

...

Maybe something will come of this??
This is a concern. I have written HTML parsers, and Fastmail should have detected an issue like this themselves. Any failure to fully parse the input should be logged, and reviewed by the responsible developer. Just silently ignoring errors that result in content being discarded is not appropriate.
BritTim is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 02:57 PM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy