EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 5 Dec 2021, 05:59 AM   #1
Stokkes
Junior Member
 
Join Date: Dec 2021
Posts: 15
Help requested - not receiving email from some providers

Hello,

New to this forum, so hello everyone! I am a bit desperate. I switched from Gmail Workplace to Fastmail on November 20, changed all my MXer, setup DKIM, etc. Since then, most email has been flowing fine on a custom domain, but there are many providers that I am not getting any email from (and they're not in the spam/trash).

Specifically, any email from a Shopify store, email from Paybright, I even purchased a Tesla and i have missed 3-4 emails from them. Calling in, their systems show that the emails are "undeliverable", but the customer service can't tell me why (they don't have the bounce backs).

Fastmail support is no help.. I can recreate the issue with Paybright easily - because with paybright they send you a 6 digit code to your email in order to login and I don't ever get thoses. There was zero problems with Gmail.

This is beyond frustration and Fastmail support is utterly useless. I don't really want to switch back to Gmail but I have no idea what else to do.. Using tools from mxtoolbox.com, everything on my domain shows as being properly configured and like I said, email is flowing for 95% of the email.

Anyone have any ideas what I could do?

Thanks
Stokkes is offline   Reply With Quote

Old 5 Dec 2021, 06:31 AM   #2
placebo
Cornerstone of the Community
 
Join Date: Jun 2004
Posts: 712
When I had some emails go missing, Fastmail support told me what they found in its logs about emails from certain addresses. What did Fastmail support tell you?
placebo is offline   Reply With Quote
Old 5 Dec 2021, 06:37 AM   #3
Stokkes
Junior Member
 
Join Date: Dec 2021
Posts: 15
They told me they don't see anything in their logs from the email addresses I gave them.

Basically, I tested with paybright.. The way Paybright logins work is that you put in your mobile #, they send you a code, then they send you a code to your email. I just did this about 10 times within 1-2 minutes and gave them the FROM address, subject, time, etc.. They told me their logs show no emails coming in.

This makes me think it's some kind of DNS or routing issue as the emails that I'm having problems receiving seem to come from mass email tools like sendgrid, Mailchiimp, etc. It would make sense that fastmail maybe didn't "see" anything in the logs if the emails are not even getting to them.

But troubleshooting this is painful. Like I said, no issues when I was on gmail. The only thing I really did was swap my MX records and DKIM record.
Stokkes is offline   Reply With Quote
Old 5 Dec 2021, 06:58 AM   #4
placebo
Cornerstone of the Community
 
Join Date: Jun 2004
Posts: 712
You might ask them to escalate the issue. I doubt first-level support has the tools or expertise to investigate this issue.

Both Citibank and American Express have at times told me that there was a problem with sending to my fastmail address. I never bothered investigating since the problem was very rare, and as far as I could tell, I was receiving the emails like payment reminders I was expecting from them. Still, there seemed to be something going on which led these companies to think my address wasn't working.

It sounds like your problem might be easier to diagnose since it's reproducible. Now that I think of it, I have a similar issue to yours with HBO Max. I've tried to verify my fastmail email address with them but I never receive the verification email.
placebo is offline   Reply With Quote
Old 5 Dec 2021, 07:03 AM   #5
Stokkes
Junior Member
 
Join Date: Dec 2021
Posts: 15
For some newsletters and stuff, yeah I could live with it.

But the fact I actually missed my first delivery window of the Tesla because they couldn't reach me (they do everything via email it seems), and that I can't even login to my Paybright account to pay off my balance since you can't login to paybright any other way..

This is just unacceptable. I mean I much prefer Fastmail but losing email or undeliverable random email is pretty much a show stopper.
Stokkes is offline   Reply With Quote
Old 5 Dec 2021, 10:38 AM   #6
Grhm
Essential Contributor
 
Join Date: Mar 2007
Location: UK
Posts: 246
That is a very serious problem! I'm sure they will want to know about it and fix it... so don't despair... persevere with the helpdesk!
My experience of Fastmail is that if you refuse to be fobbed off and you keep explaining the problem, it will eventually arrive in front of a person who understands what you are saying and knows what to do. Unlike with many other organisations.
Grhm is offline   Reply With Quote
Old 5 Dec 2021, 03:04 PM   #7
BritTim
The "e" in e-mail
 
Join Date: May 2003
Location: mostly in Thailand
Posts: 2,952
Email delivery errors in conjunction with no record in Fastmail's logs suggests that an attempt is being made to contact the wrong server.

Carefully check the MX records for your custom domain. Is it possible that you still have one MX record pointing at the server of your previous email provider? Is it possible that one of the records has a misspelling?

I would suggest using MX Toolbox to double check for configuration errors.
BritTim is offline   Reply With Quote
Old 5 Dec 2021, 11:57 PM   #8
Stokkes
Junior Member
 
Join Date: Dec 2021
Posts: 15
Yeah first thing I did was use the tools of MXtoolbox to troubleshoot. Everything seems fine, MX resolves correctly, DKIM, SPF.. all good.

As I mentioned, most email is being delivered, I'd go as far as say over 99%. It's a few key players that i'm not getting anything (the ones mentioned above).

It's absolutely baffling. Hope support wakes up (not holding my breath) or I'll have to begrudgingly switch back to Google.
Stokkes is offline   Reply With Quote
Old 6 Dec 2021, 12:14 AM   #9
bertradio
Junior Member
 
Join Date: Sep 2016
Posts: 18
Have you hecked all your spam settings? There is a custom setting which will permanently delete all emails with a spam score higher than a specified value. Also check blocked senders.
bertradio is offline   Reply With Quote
Old 6 Dec 2021, 12:24 AM   #10
Stokkes
Junior Member
 
Join Date: Dec 2021
Posts: 15
Quote:
Originally Posted by bertradio View Post
Have you hecked all your spam settings? There is a custom setting which will permanently delete all emails with a spam score higher than a specified value. Also check blocked senders.
Validated that too - Protection level is set to "Standard", Backscatter is "Move to Spam"..

There are no blocked senders or domains.
Stokkes is offline   Reply With Quote
Old 6 Dec 2021, 03:04 AM   #11
BritTim
The "e" in e-mail
 
Join Date: May 2003
Location: mostly in Thailand
Posts: 2,952
If Fastmail's claim that there is nothing in their logs related to the undelivered messages is accurate, this is quite strange, but surely suggests a problem at the sending end. A bad network route is one possibility. It is very hard to diagnose such issues without access to the sending server.

EDIT: Is it possible to change the email address you are using to a Fastmail domain address (presumably using the same MX servers) and see if mail is still undelivered? Fastmail support might be more interested in escalating their response if you can show your problem potentially affects everyone at Fastmail.

Last edited by BritTim : 6 Dec 2021 at 03:10 AM.
BritTim is offline   Reply With Quote
Old 6 Dec 2021, 04:33 AM   #12
bertradio
Junior Member
 
Join Date: Sep 2016
Posts: 18
How about setting up a rule to send a copy of all mail to another non-FM address and see if everything arrives there?
bertradio is offline   Reply With Quote
Old 6 Dec 2021, 07:50 AM   #13
Stokkes
Junior Member
 
Join Date: Dec 2021
Posts: 15
Quote:
Originally Posted by BritTim View Post
If Fastmail's claim that there is nothing in their logs related to the undelivered messages is accurate, this is quite strange, but surely suggests a problem at the sending end. A bad network route is one possibility. It is very hard to diagnose such issues without access to the sending server.

EDIT: Is it possible to change the email address you are using to a Fastmail domain address (presumably using the same MX servers) and see if mail is still undelivered? Fastmail support might be more interested in escalating their response if you can show your problem potentially affects everyone at Fastmail.
Its likely something with routing/DNS/etc. I switched my MXers back to google (my account hasn't expired yet) and got the emails from Paybright. Switched them back to Fastmail And nada.

Fastmail support did suggest the same thing - change email to a @fastmail.com address. I'm trying that but it's hard because the only thing I can change is this weekly newsletter which I get on Saturday (and haven't gotten since I switched to Fastmail). I updated my email there but will have to wait until next Saturday to see if I get it.

This is just baffling. I'm in IT professionally and really what I need to do is find a way to talk to a Fastmail admin - someone with root level access to the servers so we can see what's going on.
Stokkes is offline   Reply With Quote
Old 6 Dec 2021, 07:51 AM   #14
Stokkes
Junior Member
 
Join Date: Dec 2021
Posts: 15
Quote:
Originally Posted by bertradio View Post
How about setting up a rule to send a copy of all mail to another non-FM address and see if everything arrives there?
Tried that just now but didn't work. Thanks for the suggestion.
Stokkes is offline   Reply With Quote
Old 6 Dec 2021, 03:04 PM   #15
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,906
full records can take up to 48 hours to propagate.
Terry is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 04:18 AM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy