EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 20 Oct 2021, 09:31 PM   #1
NJSS
Master of the @
 
Join Date: Jul 2002
Location: Hampshire, UK
Posts: 1,223
Mail originating from "me"

The majority of my outgoing emails from FM are sent from my PObox.Com address, but many sent from my domain.

Those sent from FM using my Pobox address are all of a sudden shown as having been sent by "me".

I haven't changed any settings, why please is this, and how do I reset so they show as having been sent by "MyName" - i.e. "John Doe".

NJSS

Ticket raised with FM - PTN 1474859

Last edited by NJSS : 21 Oct 2021 at 06:01 PM. Reason: To add details of ticket
NJSS is offline   Reply With Quote

Old 20 Oct 2021, 11:53 PM   #2
BritTim
The "e" in e-mail
 
Join Date: May 2003
Location: mostly in Thailand
Posts: 2,934
I cannot tell you for certain what is going on. However, most likely is that there is a Sending Identity for the PObox.com address at Fastmail, and the default for the name field has changed. If I am correct, it should be easy just to go to Settings->Sending Identities and Edit the offending Identity.
BritTim is offline   Reply With Quote
Old 21 Oct 2021, 04:02 AM   #3
InfamousGrouse
Junior Member
 
Join Date: Jul 2011
Posts: 20
I've started seeing this this evening too. I regularly send myself work-related messages, either from a work address (not FastMail) to one of my home (FastMail) addresses, or from one home address to the same home address, and I have them saved or routed into the same folder for admin purposes.

Suddenly half of my messages are showing as being from "me", the other half from "Myfirstname Mylastname". As far as I can tell anything originating from my own domain has been changed to "me", while anything from my employer's domain hasn't, even though that address is also saved in my address book profile.

It's made navigating folders, in particular that "work admin" folder, a bit of a nightmare. It's particularly hard on the eyes because of the choice to use all lowercase for "me" while my full name and other full names are properly capitalised. It looks horrible.

I've had a quick look through all the settings and I can't find anywhere to turn this feature off. Whoever thought of this really ought to have run it past a focus group or two because I can't believe I'm the only one bothered by this.

I wonder if this has been introduced as a way of dealing with the new on-demand Masked Email addresses? That would make some sense as you might not want your real name on the headers of throw-away addresses.

Whatever the reason, I'll give good money (or at least kudos) to anyone who can tell me how to turn the damned thing off.
InfamousGrouse is offline   Reply With Quote
Old 21 Oct 2021, 05:20 PM   #4
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,896
I get calendar reminders its on there also.
Terry is offline   Reply With Quote
Old 21 Oct 2021, 11:16 PM   #5
BritTim
The "e" in e-mail
 
Join Date: May 2003
Location: mostly in Thailand
Posts: 2,934
Quote:
Originally Posted by InfamousGrouse View Post
I've started seeing this this evening too. I regularly send myself work-related messages, either from a work address (not FastMail) to one of my home (FastMail) addresses, or from one home address to the same home address, and I have them saved or routed into the same folder for admin purposes.

Suddenly half of my messages are showing as being from "me", the other half from "Myfirstname Mylastname". As far as I can tell anything originating from my own domain has been changed to "me", while anything from my employer's domain hasn't, even though that address is also saved in my address book profile.

It's made navigating folders, in particular that "work admin" folder, a bit of a nightmare. It's particularly hard on the eyes because of the choice to use all lowercase for "me" while my full name and other full names are properly capitalised. It looks horrible.

I've had a quick look through all the settings and I can't find anywhere to turn this feature off. Whoever thought of this really ought to have run it past a focus group or two because I can't believe I'm the only one bothered by this.

I wonder if this has been introduced as a way of dealing with the new on-demand Masked Email addresses? That would make some sense as you might not want your real name on the headers of throw-away addresses.

Whatever the reason, I'll give good money (or at least kudos) to anyone who can tell me how to turn the damned thing off.
If you have edited the Sending Identity in Fastmail for your home email to use the Name you want, and this is being ignored, my next steps would be
  • examine the full headers for the message to see if the unwanted content of the name field is being set that way when the message is created, or is being modified somehow in transit (which would cause other problems other than just a bad name field); and
  • if there is no clear explanation for the behaviour, contact support, explaining that the settings in your Sending Identity are being ignored.
BritTim is offline   Reply With Quote
Old 22 Oct 2021, 06:22 PM   #6
NJSS
Master of the @
 
Join Date: Jul 2002
Location: Hampshire, UK
Posts: 1,223
I have received a response from FM Support:-

Quote:
When there are multiple people in a conversation, we often need to shorten names in the message list to just first name and last initial to fit into the available space.

We recently made a change to show any emails from you as the name 'me'. Please be assured that it will only display as such for emails within the account. Recipients will continue to see the display name set on the Settings → Sending Identities page.

We did this to allow us to show more of other people's names in the email list.

I am sorry this change was a concern for you.
NJSS
NJSS is offline   Reply With Quote
Old 26 Oct 2021, 05:31 PM   #7
InfamousGrouse
Junior Member
 
Join Date: Jul 2011
Posts: 20
This was wholly a display change within the web (and possibly mobile) apps. All of the outgoing headers were identical, and third-party clients displayed them as is. At least we know from OP's quoted response that the change was deliberate.

Interestingly I've just gone into two of my catch-all folders and I'm not seeing this behaviour any more. None of the previously affected messages has the "me" in any column or header.

Three possibilities spring immediately to mind:
  • FastMail have deliberately removed this feature due to backlash (I haven't seen much actual backlash in public spaces, but maybe they had lots of support tickets...)
  • They have tweaked it so it only applies when there are multiple recipients in the relevant fields. A quick check of a message sent to me and multiple others suggests this isn't the case but I only checked a single, older, message.
  • Mitigating the recent DDOS/outage has necessitated a rollback to earlier code without the change, and the change will come again with the next update.
Or, of course, something I haven't thought of. Going to keep an eye on this though. For such a minor change it was disproportionately irritating and I'm glad it's gone.
InfamousGrouse is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 04:42 PM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy