EmailDiscussions.com  

Go Back   EmailDiscussions.com > Miscellaneous > About this site...
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

About this site... Do you have any thoughts, suggestions or comments about this site? Post them here...

Reply
 
Thread Tools
Old 27 Jan 2022, 03:19 PM   #1
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,950
Why dont EMD have a secure site

Why no https:
Terry is offline   Reply With Quote

Old 27 Jan 2022, 04:39 PM   #2
Berenburger
The "e" in e-mail
 
Join Date: Sep 2004
Location: The Netherlands
Posts: 2,818
This has been covered here before.
Berenburger is offline   Reply With Quote
Old 27 Jan 2022, 05:11 PM   #3
Terry
The "e" in e-mail
 
Join Date: Jul 2002
Location: VK4
Posts: 2,950
May have been me I forget....
Terry is offline   Reply With Quote
Old 27 Jan 2022, 05:37 PM   #4
BritTim
The "e" in e-mail
 
Join Date: May 2003
Location: mostly in Thailand
Posts: 3,010
EMD is a legacy website with no ongoing development for many years. The owners do not want to spend time doing anything that is not 100% necessary to keep the site running. Just be grateful that the site has not been turned off like so many legacy free sites.

That said, setting up Let's Encrypt certificates, with the script for automated renewal is pretty straightforward in most cases, and would certainly be nice.
BritTim is offline   Reply With Quote
Old 27 Jan 2022, 06:29 PM   #5
FredOnline
The "e" in e-mail
 
Join Date: Apr 2011
Location: Manchester UK
Posts: 2,602
Quote:
Originally Posted by Berenburger View Post
This has been covered here before.
And it's in the wrong forum! EDIT: This thread has now been moved to the correct forum, it was originally in the Fastmail forum!

It's the way the website has been coded, for example - looking at view page source:

Quote:
<a href="http://www.emaildiscussions.com/"><img src="emaildiscussions.gif" border="0" alt="EmailDiscussions.com" /></a>
All links appear to have the full URL beginning http:// (instead of just index.html, for example) so of course it will revert to that, even if you call up:

https://www.emaildiscussions.com/

Whenever you subsequently click on any link, it's back to http://

Whether or not that's the fault of Edwin or the software, I don't know.

Last edited by FredOnline : 28 Jan 2022 at 03:13 PM.
FredOnline is offline   Reply With Quote
Old 27 Jan 2022, 06:51 PM   #6
BritTim
The "e" in e-mail
 
Join Date: May 2003
Location: mostly in Thailand
Posts: 3,010
Quote:
Originally Posted by FredOnline View Post
And it's in the wrong forum!

It's the way the website has been coded, for example - looking at view page source:



All links appear to have the full URL beginning http:// (instead of just index.html, for example) so of course it will revert to that, even if you call up:

https://www.emaildiscussions.com/

Whenever you subsequently click on any link, it's back to http://

Whether or not that's the fault of Edwin or the software, I don't know.
It should be noted that a global automatic redirect is not difficult to implement in most cases. However, with such an old site, who knows what kind of gotchas might exist?
BritTim is offline   Reply With Quote
Old 29 Jan 2022, 02:34 PM   #7
Bamb0
Master of the @
 
Join Date: Feb 2005
Location: USA
Posts: 1,606
Why???

What are you trying to hide?

We arent transferring missile codes here....... Dont drink the koolaid for goodness sakes
Bamb0 is offline   Reply With Quote
Old 29 Jan 2022, 05:04 PM   #8
chrisretusn
Cornerstone of the Community
 
Join Date: Aug 2006
Location: Philippines
Posts: 784
Quote:
Originally Posted by BritTim View Post
However, with such an old site, who knows what kind of gotchas might exist?
HTTPS protocol would not protect you from gotchas.

Last edited by chrisretusn : 30 Jan 2022 at 02:31 PM. Reason: left out a key word "not"
chrisretusn is offline   Reply With Quote
Old 30 Jan 2022, 03:11 AM   #9
Bamb0
Master of the @
 
Join Date: Feb 2005
Location: USA
Posts: 1,606
It just adds alot of overhead we dont need.....
Bamb0 is offline   Reply With Quote
Old 24 Feb 2022, 09:40 AM   #10
Bamb0
Master of the @
 
Join Date: Feb 2005
Location: USA
Posts: 1,606
Lightbulb

I am on firefox right now and am testing the https side and it IS working 100% for those who want to use it..

https://www.emaildiscussions.com

Does keep me on the https side for most of my session but I dont usually use it,just testing it.
Bamb0 is offline   Reply With Quote
Old 24 Feb 2022, 02:32 PM   #11
chrisretusn
Cornerstone of the Community
 
Join Date: Aug 2006
Location: Philippines
Posts: 784
I am also using Firefox (97.0.1), my bookmark URL is https://www.emaildiscussions.com/

As I am typing this post the URL is http://www.emaildiscussions.com/newreply.php?do=newreply&noquote=1&p=625007

I opened this page by right clicking the scroll wheel mouse button on the thread title to open it in back ground in a new tab.

The behavior is not consistent. Most oft the time when I repeat the above steps for other subjects to open them in a new tab, it does come up with https, but not always.

That this site is not 100% https does not bother me at all. The site is open to everyone for lookie-loo access. When I log in, and submit my password it's always https. This is the only time the secure connection is needed anyway.

Last edited by chrisretusn : 24 Feb 2022 at 02:38 PM.
chrisretusn is offline   Reply With Quote
Old 16 Apr 2022, 01:34 AM   #12
jdtaylor
Master of the @
 
Join Date: Sep 2004
Posts: 1,646
Google chrome does the same for the homepage.
jdtaylor is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 03:23 AM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy