EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 30 May 2024, 03:47 PM   #1
fernandoepps
Junior Member
 
Join Date: May 2024
Posts: 1
Issue with Fastmail search

Hello,
I am having an issue, and a ticket I submitted has been escalated to developers (so they say) but the issue still exists. I do a simple search for a single word. I was searching for a software package I knew I bought awhile ago but search was not showing any results. I had to dig through my folders and sure enough it was there. I opened a ticket and they had me create a special folder and copy the email there so they could investigate. I did and even found others too. I copied those to the folder as well for them and they can see the same thing I am but no resolution and now ticket is just stale. What sucks is I paid for 3 years a month ago. I also updated accounts with masked emails at over 30 places so it is not something I can just move away from at this point.
fernandoepps is offline   Reply With Quote

Old 30 May 2024, 04:26 PM   #2
Avion
Senior Member
 
Join Date: Sep 2022
Posts: 104
FYI, this exact same question was posed on Reddit:

https://www.reddit.com/r/fastmail/co...stmail_search/
Avion is offline   Reply With Quote
Old 30 May 2024, 04:59 PM   #3
JeremyNicoll
Essential Contributor
 
Join Date: Dec 2017
Location: Scotland
Posts: 494
According to the reddit post, the OP didn't include double quotes around their single-word search argument.

That means that FM will have done their sort of fuzzy search (what they call 'stemming') of related words.

These days I ALWAYS put double quotes around search arguments.


Also ... the OP said the argument was a 'word'. Was this a 'word' (ie single string of non-whitespace characters, but not just letters), eg "sox123" or "Fantastic-Prog-v123" (both of which would be classed as 'word's in some programming languages), or was it made up from letters only?

If it did have non-letters in it, I think that might require double quotes.
JeremyNicoll is offline   Reply With Quote
Old 30 May 2024, 05:12 PM   #4
hadaso
The "e" in e-mail
 
Join Date: Oct 2002
Location: Holon, Israel.
Posts: 4,894
I think sometimes search doesn't find words if they are broken across header lines, or if they are internally broken across lines in the message body (that is, when viewing the email message, they look whole, but when viewing the raw message that is encoded with BASE64 or QP they are in two separately encoded lines).
hadaso is offline   Reply With Quote
Old 24 Jun 2024, 08:58 PM   #5
bipbop
Senior Member
 
Join Date: Dec 2009
Posts: 198
I came here today because of I've experienced the same. I have a mail that can't be found even when I use "Anywhere".

I found that if I search for an exact word in a Subject, it finds it. But if I search for parts of the word, it finds nothing. Like "Guardian" is found. But "Guard" is not.

Just thought I'd post my experience here..
bipbop is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 04:11 PM.

 

Copyright EmailDiscussions.com 1998-2022. All Rights Reserved. Privacy Policy