EmailDiscussions.com  

Go Back   EmailDiscussions.com > Email Service Provider-specific Forums > FastMail Forum
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read
Stay in touch wirelessly

FastMail Forum All posts relating to FastMail.FM should go here: suggestions, comments, requests for help, complaints, technical issues etc.

Reply
 
Thread Tools
Old 24 Nov 2014, 07:36 AM   #91
randian
Cornerstone of the Community
 
Join Date: Jan 2014
Posts: 561
Quote:
Originally Posted by robn View Post
You seemed to be talking about the ability to delete a message, and as you found, the functionality is there, just inconvenient to access. Have I misunderstood?
No. My complaint is the inconsistent UI not having swipe to delete/archive everywhere you access a message, not that delete itself is missing.
randian is offline   Reply With Quote
Old 24 Nov 2014, 07:38 AM   #92
DelftRed
Junior Member
 
Join Date: Nov 2014
Location: Adelaide
Posts: 13
Quote:
Originally Posted by robn View Post
Interesting. So to clarify, the the notifications still fire even during the quiet period? What time period have you set, and what time is it when the notification appears? Those numbers will let me check the logic is right.
Yes, that's right, I still received the notifications (sound at least, I didn't pay attention to the LED). My "Quiet start time" was 23:30, and my Quiet end time was 6:30. Although I varied the start time by +-30 minutes to test if it was something to do with my time zone being in Adelaide (with its odd 9:30 offset to GMT). I tested it by sending myself emails from my laptop, and I couldn't get it to be silent with any settings I was trying.
DelftRed is offline   Reply With Quote
Old 24 Nov 2014, 07:41 AM   #93
robn
Master of the @
 
Join Date: May 2012
Location: Melbourne, Australia
Posts: 1,007

Representative of:
Fastmail.fm
Quote:
Originally Posted by randian View Post
No. My complaint is the inconsistent UI not having swipe to delete/archive everywhere you access a message, not that delete itself is missing.
I see. Where would you swipe? The entire message, or somewhere else?

We've pretty much decided from our testing that left/right gestures in the message view aren't particularly discoverable and don't have an obvious function, particularly across platforms (eg iOS uses left-to-right for back in many apps, which feels very odd in the FastMail app for some reason).

It doesn't seem to be a consistency issue because its a different view, with a different layout and different meaning.

Do you know of any other apps that do implement the same action gestures in a content list and a content view? I'd like to try them.
robn is offline   Reply With Quote
Old 24 Nov 2014, 07:45 AM   #94
robn
Master of the @
 
Join Date: May 2012
Location: Melbourne, Australia
Posts: 1,007

Representative of:
Fastmail.fm
Quote:
Originally Posted by DelftRed View Post
Yes, that's right, I still received the notifications (sound at least, I didn't pay attention to the LED). My "Quiet start time" was 23:30, and my Quiet end time was 6:30. Although I varied the start time by +-30 minutes to test if it was something to do with my time zone being in Adelaide (with its odd 9:30 offset to GMT). I tested it by sending myself emails from my laptop, and I couldn't get it to be silent with any settings I was trying.
Thanks for the info, and for testing. I'll do some tests myself and see what's going on. 23:30+:30 is midnight, so a different day, which might be making it set the quiet period to be 06:30-00:00. I can't quite think why at this stage, but there's a smell there that I want to have a look at
robn is offline   Reply With Quote
Old 24 Nov 2014, 08:06 AM   #95
onmyway
Junior Member
 
Join Date: Nov 2014
Posts: 2
Notifications

Quote:
Originally Posted by Adon View Post
Looks like this app is just a web page (mobile web interface) wrapped in an executable and not a native Android app (like Gmail) and its only advantage is push notifications ...
This approach is perfect for me, and thank you to the devs for getting started along this path

I seem to be running into an initial issue though, and I've quadruple checked the Device settings, rebooted/reinstalled several times of course ... On my HTC One (Android 4.0.4 HTC SDK 4.23) I am not getting push notifications.

Any known fixes? Apologies if I've missed something obvious.
onmyway is offline   Reply With Quote
Old 24 Nov 2014, 08:16 AM   #96
robn
Master of the @
 
Join Date: May 2012
Location: Melbourne, Australia
Posts: 1,007

Representative of:
Fastmail.fm
Quote:
Originally Posted by onmyway View Post
I seem to be running into an initial issue though, and I've quadruple checked the Device settings, rebooted/reinstalled several times of course ... On my HTC One (Android 4.0.4 HTC SDK 4.23) I am not getting push notifications.
4.0.4 is down at the bottom of what we support, so I hope there's not some subtle platform problem.

Just to confirm, you've got this from the Play Store? I'm getting a few reports of "no notifications" from people that are sideloading the app because they don't want to use Google Services. Notifications require Google's push channel at the moment.

If that's all fine, can you please PM me your FastMail username so I can check the push backend and see if anything strange is happening.
robn is offline   Reply With Quote
Old 24 Nov 2014, 06:45 PM   #97
onmyway
Junior Member
 
Join Date: Nov 2014
Posts: 2
Yes the app was downloaded directly through Google Play. Thank you for looking at this, pm sent.
onmyway is offline   Reply With Quote
Old 1 Dec 2014, 11:12 AM   #98
Merovingian
Master of the @
 
Join Date: Aug 2007
Location: U.S.A.
Posts: 1,583
Quote:
Originally Posted by robn View Post
4.0.4 is down at the bottom of what we support, so I hope there's not some subtle platform problem.

Just to confirm, you've got this from the Play Store? I'm getting a few reports of "no notifications" from people that are sideloading the app because they don't want to use Google Services. Notifications require Google's push channel at the moment.

If that's all fine, can you please PM me your FastMail username so I can check the push backend and see if anything strange is happening.

I also have this issue of not getting notifications on my phone with the mobile app (Android).. I'm running Android 5.0 Lollipop. It's been working just fine until a few moments ago? I've made sure I don't have quiet hours set, and just to make sure I set the quiet hours not to start until a few hours from now, then also unclicked the box.


I've just PM'd you my username.

thank you so much!

Last edited by Merovingian : 1 Dec 2014 at 11:56 AM.
Merovingian is offline   Reply With Quote
Old 2 Dec 2014, 01:49 AM   #99
mekitron
Senior Member
 
Join Date: Dec 2014
Location: Central City
Posts: 162
Lightbulb Gestures and Files

I have couple of suggestions that RTL and LTR gestures (to delete/archive) should be revised. I just deleted one threaded email (though, undo came handy). It'll be great if user could decide the process of deleting or archiving a complete thread.

I really want to access my files on mobile; if you haven't decided to work on it yet then please do it.

I setup signature in webmail (which contains links) but app is not retrieving it properly. It'll be appreciative if app could retrieve the signature as it is in browser or at least it could auto sign the email, "sent from xxxx".

thanks
mekitron is offline   Reply With Quote
Old 2 Dec 2014, 02:26 PM   #100
aqeeliz
Junior Member
 
Join Date: Feb 2014
Posts: 26
Quote:
Originally Posted by mekitron View Post
I have couple of suggestions that RTL and LTR gestures (to delete/archive) should be revised. I just deleted one threaded email (though, undo came handy). It'll be great if user could decide the process of deleting or archiving a complete thread.
Gmail app behaves kind of same, and it's quite annoying when you accidently delete/archive something, fortunately they provide an undo button too.

Maybe with time these will become de facto standards and everyone will get used to these.
aqeeliz is offline   Reply With Quote
Old 6 Dec 2014, 07:08 PM   #101
randian
Cornerstone of the Community
 
Join Date: Jan 2014
Posts: 561
The new http client has introduced intermittent multi-second delay in updating the inbox view. For example, if I tap on a notification bar it may be several seconds before the app displays the new email. Updates as a result of other client actions can also be delayed. This did not happen before this change.
randian is offline   Reply With Quote
Old 6 Dec 2014, 08:01 PM   #102
robn
Master of the @
 
Join Date: May 2012
Location: Melbourne, Australia
Posts: 1,007

Representative of:
Fastmail.fm
Quote:
Originally Posted by randian View Post
The new http client has introduced intermittent multi-second delay in updating the inbox view. For example, if I tap on a notification bar it may be several seconds before the app displays the new email. Updates as a result of other client actions can also be delayed. This did not happen before this change.
The HTTP client changes has nothing to do with the display - its all in the background notifier process. There was some corresponding webapp changes that went out at the same time though. I haven't noticed any difference and haven't heard any other reports, but I'll look into it further all the same.
robn is offline   Reply With Quote
Old 6 Dec 2014, 08:42 PM   #103
randian
Cornerstone of the Community
 
Join Date: Jan 2014
Posts: 561
Quote:
Originally Posted by robn View Post
The HTTP client changes has nothing to do with the display - its all in the background notifier process.
I just noticed delays. I don't know what's causing them. I'm also seeing cases where the display says there's a new email in INBOX (the count shows, for example, 3), but switching to INBOX may not show those new emails for a good 5 seconds or more. It doesn't always do that, but it was always instantaneous before. This delay is not accompanied by the scrolling lines that sometimes appear while it's waiting for something.
randian is offline   Reply With Quote
Old 7 Dec 2014, 10:49 AM   #104
robn
Master of the @
 
Join Date: May 2012
Location: Melbourne, Australia
Posts: 1,007

Representative of:
Fastmail.fm
I can't think of any particular change that would cause this, and I don't see it here. Are you able to try the webmail in Chrome? I'm curious to know if the same thing happens there.
robn is offline   Reply With Quote
Old 9 Jan 2015, 04:13 PM   #105
Drencrom
Master of the @
 
Join Date: Nov 2002
Location: Ultima Thule
Posts: 1,657
When I open the message in the FM Android app and tap on "Download" next to an attachment - there is no reaction whatsoever. I am using Nexus 5, Android version 4.4.4.
Drencrom is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +9. The time now is 12:53 PM.

 

Copyright EmailDiscussions.com 1998-2013. All Rights Reserved. Privacy Policy